aeSecure est disponible en plusieurs langues (dont l'Anglais, le Néerlandais, le Brésilien, le Portugais et le Russe -pour les langues à 100% traduites-).

L'installateur d'aeSecure (fichier aesecure.php) mentionne "votre" langue càd soit celle définie dans votre profil utilisateurs (sur le site aeSecure.com) soit la langue du site.  

Durant les premiers jours de mise à disposition de l'installateur d'aeSecure 2.0, la langue était mal détectée et l'installateur était programmé avec l'Anglais comme langue par défaut.

J’ai déjà eu l’occasion à plusieurs reprises de mentionner le danger que représente le fichier robots.txt qui se trouve à la racine de votre site web. On y accède simplement depuis l’url https://lesite/robots.txt.

Ce fichier est destiné aux bots; ces scripts des moteurs de recherche afin de leur expliquer ce qu’ils peuvent ou ne peuvent pas faire : ils peuvent indexer tel ou tel dossier ou fichier, ils ne peuvent pas indexer tel ou tel fichier. Attention de bien comprendre: vous leur "demandez" de respecter le fichier; ce que font les bots honnêtes. Ils ne sont aucunement contraints de le faire. Un peu comme la nétiquette pour les humains.

Si, juste après l'activation d'aeSecure (option 1.1), vous constatez une erreur 404 ou 500 (erreur serveur) sur votre site, veuillez vérifier que l'option 7.1 - Réécriture des URLs permettant la réécriture des URLs est bien activée.  En effet, si l'URL visitée sur votre site est "réécrite", il convient de s'assurer que le fichier .htaccess mis en place par aeSecure reprenne la règle pour la réécriture, ce que fait l'option 7.1.

Si vous devriez rencontrer un cas où les permissions du fichier configuration.php ont "sautées" càd que votre fichier n'est plus accessible par Joomla!® et que le chmod du fichier est absent (000), copiez/coller le code ci-dessous dans un fichier texte que vous nommerez chmod.php et que vous placerez ensuite à la racine de votre site; dans le même dossier que le fichier configuration.php puis accéder à l'URL http://votresite/chmod.php.

A l'activation ou à la désactivation de l'option 1.1 Mise en place du fichier .htaccess d'aeSecure, vous recevez une erreur telle que (le nom du fichier et le numéro de ligne pouvant varier) :

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/xxxx/www/aesecure/helpers/aesecure.php on line 14

Cette erreur est dûe à la version "par défaut" de PHP sur votre serveur web.

Dans certains écrans d'aeSecure, vous pourriez voir apparaître un bouton "Restaurer" comme ci-dessous.

Considérez l'exemple suivant : vous avez passé un temps conséquent à paramétrer toutes les redirections sur votre site afin d'éviter les pages 404 (option 7.4), vous avez modifié manuellement une portion de votre .htaccess (option 1.4), vous avez configuré votre fichier robots.txt (option 7.3) et ... catastrophe, vous constatez que la zone est vide. Vous pourriez avoir supprimé par erreur votre .htaccess ou l'avoir remplacé par une ancienne version.  Avez-vous perdu toute votre configuration ? Non !

Prêt à sécuriser votre site web ? Télécharger